Willkommen Gast 

Infos ein-/ausblenden

Willkommen Gast! Um Beiträge zu verfassen musst Du registriert sein.





Seiten: [1]
Autor Thema:Dateien fehlen im Backup
MatthiasSt-
olte
Neuling
Beiträge: 3
Permalink
avatar
Beitrag Dateien fehlen im Backup
am May 12, 2020, 17:13
Zitat

Jüngst hatte ich Verzeichnisse auf dem Server die (roaming) Windows-Profilordner der User sowie der durch HLB angelegten Kopien verglichen und Unterschiede festgestellt. Und tatsächlich fehlen auf dem Backupmedium einige Dateien, die auf dem Quelldatenträger vorhanden sind. Beispiel: die Dateien im "adblockplus"-Verzeichnis (Firefox-Profil) fehlen, und zwar von allen (!) Benutzern. Das Logging habe ich auf "Detailliert" gestellt, und dort findet sich jeweils pro Benutzer nur der Eintrag

MSG: Creating directory "S:\2020-05-11\ServerFolders\profiles\Test.V2\AppData\Roaming\Mozilla\Firefox\Profiles\4cipcy06.default\adblockplus"

HLB-2.2.19 auf SBS2011 (16 GB RAM, Soft-RAID1), Sicherung auf 4 TB USB-HDD

PS: Gibt es keine Vorschau des Beitrags? 😯

lupinho
Administrator
Beiträge: 678
Permalink
avatar
Beitrag Re: Dateien fehlen im Backup
am May 13, 2020, 00:20
Zitat

Dateien „fehlen“ nicht einfach im Backup. HardlinkBackup kann nur die Dateien sichern, auf die der Backup-User oder der User „System“ Zugriff haben. Wenn die Dateien bzw. das Verzeichnis ungünstige Zugriffseinstellungen haben, kann es sein, dass die Dateien von HardlinkBackup nicht gesehen werden. Bitte prüfe also die Berechtigungen für die betroffenen Verzeichnisse bzw. Dateien!

MatthiasSt-
olte
Neuling
Beiträge: 3
Permalink
avatar
Beitrag Re: Dateien fehlen im Backup
am May 13, 2020, 15:27
Zitat

Das war mit das Erste, was ich geprüft, allerdings oben nicht erwähnt habe: HLB wird unter dem Konto "Administrator" ausgeführt. Die fraglichen Dateien gehören zwar dem User, aber SYSTEM und die Gruppe "Administratoren" haben "Vollzugriff". Mittels des Windows-Explorers kann ich die Dateien öffnen und auch in dasselbe Verzeichnis duplizieren. Merkwürdigerweise gibt es in einem anderen Unterverzeichnis des Profils Dateien mit denselben Sicherheitseinstellungen, die anstandslos kopiert wurden.
...
Eben habe ich bemerkt, dass der "Link-Script-Modus" aktiviert war - möglicherweise durch einen Doppelklick bei dem Versuch, die Backup-Einstellungen zu öffnen? Ich habe es auf "Hardlink" zurückgesetzt und werde berichten, ob der nächste Backuplauf die fraglichen Dateien gesichert hat.

MatthiasSt-
olte
Neuling
Beiträge: 3
Permalink
avatar
Beitrag Re: Dateien fehlen im Backup
am May 14, 2020, 15:45
Zitat

Siehe da: kaum macht man's richtig, funktioniert es auch 😀
Ursache der fehlenden Dateien war der fälschlicherweise eingestellte "Link-Script-Modus".

PS: Obwohl ich seit über 30 Jahren in der Branche tätig bin, u.a. selbst programmiere und damit kein unbeschriebenes Blatt in Bezug auf den Entwurf von UI bin, finde ich die Benutzerführung von HLB etwas verwirrend: Man muss auf gut Glück hier oder da klicken, drücken, doppelklicken oder wasauchimmer probieren, um Programmaktionen auszuführen.
Nach dem Start von HLB werden die Bedienelemente werden erst nach geraumer Zeit angezeigt, ohne dass der Benutzer weiß, ob "noch was kommt" oder nicht. Zum Beispiel habe ich eben gerade aus Versehen ein Backup gestartet, weil ich in einen weißen Bereich geklickt habe, in dem wohl später ein Icon aufgetaucht wäre.

Vielleicht lässt sich da etwas verbessern...

delta_back-
up
Neuling
Beiträge: 8
Permalink
avatar
Beitrag Re: Dateien fehlen im Backup
am May 14, 2020, 23:54
Zitat

Die Einschätzung kann ich absolut nicht nachvollziehen. HLB hat einen übersichtlichen Aufbau und hilfreiche Erklärungen zu den Funktionen.

Seiten: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Die Seite wurde geladen in: 0.049 Sekunden.