HardlinkBackup

Logo HardlinkBackupHardlinkBackup ist ein einfaches, schnelles Backup-Programm für inkrementelle Backups, das Hardlinks benutzt, Backups planen, E-Mail-Benachrichtigungen versenden und automatisch alte Backups löschen kann. HardlinkBackup liest die Quellverzeichnisse ein und vergleicht die Dateien mit früheren Backups. Nur die geänderten Dateien werden anschließend kopiert, die unveränderten Dateien werden mit Hard-Links mit den Dateien der bereits bestehenden Backups verlinkt (Voraussetzung ist, dass das Ziellaufwerk Hardlinks unterstützt, also z.B. mit NTFS formatiert wurde). Auf diese Art und Weise befindet sich auf dem Backup-Laufwerk immer eine komplette Kopie der Quellverzeichnisse vom jeweiligen Datum. Jedoch wird nur der Platz einer Kopie plus der veränderten Dateien benötigt. Wird eine alte Backup-Kopie nicht mehr benötigt kann sie ohne Probleme entsorgt werden, indem einfach das entsprechende Backup-Verzeichnis gelöscht wird. Von der Idee her entspricht HardlinkBackup dem rsyncbackup.vbs der Zeitschrift c’t, erweitert um eine grafische Benutzeroberfläche und viele weitere Features.

HardlinkBackup
Aktuelle Version: Version 2.2.23 (Build 9214) vom 05.07.2021
Download:
(32-bit version) oder (64-bit version) Größe: ca. 8,79 MB
Readme/Changes: ReadMe.txt Bitte beachten Sie die Lizenzvereinbarung.
Handbuch/Hilfe: Download (PDF, deutsch)
Unterstützte Betriebssysteme: Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows Server 2008 R2, Windows 7, Windows 8/8.1, Windows Server 2012, Windows 10, Windows Server 2016, Windows Server 2019
Lizenzen: Community Lizenz Professional Lizenz Enterprise Lizenz
Preis: kostenlos 39 € 69 €
Einsatzgebiet: Nicht-Kommerziell Nicht-Kommerziell Kommerziell
Sprachunterstützung: Englisch, Deutsch, Französisch, Spanisch
Features:
Schnelle, inkrementelle Sicherung beliebig großer Verzeichnisse Ja Ja Ja
Verschiedene Backup-Modi (Hardlink, Linkskript, Move, Mirror) Ja Ja Ja
Verwendung von Hardlinks (platzsparende Sicherung) Ja Ja Ja
Wiederherstellung mit Windows-Bordmitteln (Kein Programm notwendig) Ja Ja Ja
Sicherung auf lokalen, USB & Netzlaufwerken sowie Unterstützung vieler NAS Ja Ja Ja
Unterstützung langer Pfad- und Dateinamen Ja Ja Ja
Intuitive Benutzeroberfläche Ja Ja Ja
Management von mehreren Backups Ja Ja Ja
Sicherung von Linkstrukturen (Ermöglicht Backup von Backups) Ja Ja Ja
Überprüfen und Wiederherstellen von Backups Ja Ja Ja
Sichern von geöffneten Dateien   Ja Ja
Planung automatisierter Backups   Ja Ja
Emailbenachrichtigung   Ja Ja
Automatisches, regelbasiertes Aufräumen von Backups   Ja Ja
Batchmodus (Ausführen mehrerer Backups nacheinander)   Ja Ja
Erkennung verschobener und umbenannter Dateien   Ja Ja
Differentielle Sicherung großer Dateien   Ja Ja
Unterstützung für Notebook-Backup (Überwachung von Ziellaufwerk und Netzwerkverbindung)   Ja Ja
Durchführung von Skripten vor und nach dem Backup   Ja Ja
Verwendung zweier Backupziele gleichzeitig     Ja
Kommerzielle Nutzung     Ja
Erwerb über Partner: HardlinkBackup, Download bei heise
  Alternativ kann HardlinkBackup auch direkt beim Autor erworben werden (Achtung: längere Bearbeitungszeiten). Einfach E-Mail an software@lupinho.net.

Screenshots:

  1. avatar
    Bastian
    25. Februar 2015, 23:48 | #1

    Toll, jetzt funktioniert es – aber keine Ahnung, woran es lag. Ich hatte auf dem NAS eigentlich alle Rechte an den Nutzer vergeben. Wie man den Benutzer zum Besitzer des Ordners auf der DS macht habe ich nicht herausgefunden. Ich habe nur im Windows Explorer unter Sicherheit alle Berechtigungen, die irgendwem was verweigert haben gelöscht. Werde das versuchen noch mal rauszubekommen.
    Komisch war halt nur, dass ich vorher mit dem gleichen Benutzer, der Hardlinkbackup ausführt Ordner und Dateien angelegt habe und diese auch gelöscht habe. Die Rechte hatte er also offensichtlich. Die Logdatei konnte Hardlinkbackup ja auch samt Ordner anlegen…
    Auf jeden Fall vielen Dank für die Unterstützung!

  2. avatar
    Olaf
    4. Juni 2015, 14:25 | #2

    Hi,
    Ich nutze Hardlinkbackup mit der Professional Lizenz. Ich bin jetzt zu Win 8.1 umgezogen und wollte hier das automatische Backup beim anstecken einer Platte aktivieren. Dies funktioniert allerdings nicht. So wie es aussieht, behandelt Win 8 meine USB-Festplatten allesamt als „Lokale Datenträger“, und nicht als Wechseldatenträger. Gibt es hier einen Trick, dass das der automatische Backupstart doch funktioniert oder wäre dazu eine Änderung an HardlinkBackup nötig?

    mfg. Olaf

  3. avatar
    technik-bastian
    18. Juli 2015, 18:30 | #3

    Hallo,
    ich benutze hlbu schon recht lange und bin sehr zufrieden. Heute ist mir jedoch was seltsames aufgefallen. Ich habe an meiner Musiksammlung gearbeitet und im speziellen mein Bob-Dylan-Alben. Das sind recht viele und ich habe sie als flac- und mp3-Dateien. Es handelt sich (ohne Cover und Log-Files) um 943 Dateien. Die habe ich auch alle bearbeitet. Ich habe die alten Cover entfernt, die Tags zunächst entfernt und dann neu geschrieben. Weil das ganze ein paar Stunden gedauert hat, habe ich danach eine Sicherung gemacht. Es müssten also mehr als die 943 Dateien kopiert worden seien, dann neben den schon erwähnten Covern und Logfiles, kamen auch ein paar weitere Dateien der persönlichen Ablage hinzu.
    Seltsamerweise hat hlbu nur 794 Dateien kopiert. Das macht mich jetzt etwas nervös, weil damit nicht der gesamte Stand meiner Bearbeitung gesichert ist. Wie kann das sein? Mache ich irgendwas falsch? Wie stellt hlbu die Änderungen denn überhaupt fest?
    Vielen Dank vorab für alle guten Tipps…
    Gruß,
    Bastian

    • 18. Juli 2015, 22:14 | #4

      HardlinkBackup erkennt die Änderungen an Dateien schon zuverlässig. Insofern würde ich annehmen, dass Deine Sorgen unberechtigt sind. Genau kann ich es aber nicht sagen, dazu müsste man genauer drauf gucken. Wenn Du magst, kannst Du mir mal die Log-Datei und die HBI-Datei an software@lupinho.net zusammen mit ein paar Angaben, welche Dateien Du geändert hast und welche Dir fehlen, schicken. Vielleicht kann ich Dir dann genauer Auskunft geben. Prinzipiell findest Du detaillierte Angaben darüber, was passiert ist, in der Logdatei.
      Gruß,
      Lupinho.

  4. avatar
    technik-bastian
    19. Juli 2015, 16:12 | #5

    Hmm, ich habe jetzt mal versucht, das Problem genauer nachzuvollziehen.
    Zunächst habe ich die Sicherung von gestern gelöscht und die Indexdateien der vorherigen auch gelöscht, so dass das Backup ohne diese ablief.
    Im Ergebnis wurde (praktisch) die gleiche Anzahl von Dateien gesichert: 795
    Dann habe ich einen Vergleich der Dateien der Sicherung nach Inhalt mit dem Total-Commander-Tool „Verzeichnis synchonisieren“ gemacht. Dieser hat mir dann eine ganze Reihe von Dateien gezeigt, die in Original und Backup NICHT übereinstimmen.
    Exemplarisch habe ich mir davon eine Datei rausgesucht. Hier die zugehörige Zeile aus der Log-Datei:
    [11:22:55.10] MSG: Hardlink „W:\2015-07-12\Z\Musik\_flac\Bob Dylan\Another Side Of Bob Dylan1 – All I Really Want To Do.flac“ to „W:\2015-07-19\Z\Musik\_flac\Bob Dylan\Another Side Of Bob Dylan1 – All I Really Want To Do.flac“
    Ich habe für diese Datei dann eine MD5-Prüfsumme auf der Rechnerplatte erzeugt und damit die Datei der Sicherung überprüft und im Ergebnis erhalten, dass die Prüfsumme NICHT stimmt. Das war zu erwarten, denn die Datei wurde ja bearbeitet und nicht kopiert.
    Woran kann das liegen? Scheinbar sind hier die Dateigrößen zufällig identisch – bringt das Hardlinkbackup aus dem Tritt?
    Habe dir, luphino, alle Dateien und die TotalCommander-Ausgaben mal per Mail geschickt…

  5. avatar
    Mirko
    1. August 2015, 18:04 | #6

    Hi,
    ich nutze hardlinkbackup zur Sicherung einiger Daten auf zwei externe Laufwerke. Dabei ist mir aufgefallen, dass die Verlinkung auf der einen externen Platte ca. um Faktor 10 schneller geht (ca. 1 GB/s). Wenn ich die Sicherung auf die zweite externe Platte durchführe, beträgt die Link Performance nur ca. 100 MB/s. Dabei werden die gleichen Quelldaten gesichert. Ich habe schon eine ganze Menge zum Thema Performance bei Hardlinks recherchiert, leider wenig gefunden. Die Platten sind identisch formatiert mit 4096 Byte ntfs Clustersize. Die Unterschiede der Platten sind:

    Platte 1: USB 2.0, 1.5 TB, 512 Byte physische und logische Sektorgröße
    Platte 2: USB 3.0, 2.0 TB, 4 KByte physische Sektorgröße, 512 logische Sektorgröße

    Platte 1, also die USB 2.0 Platte ist die schnellere!

    Hat jemand eine Idee?

  6. avatar
    Andreas Bank
    4. August 2015, 07:55 | #7

    Gibt es schon erste Erfahrungen zu Windows 10?

    Ich benutze seit Jahren die Pro Version und stehe kurz vor dem Umstieg auf Windows 10.
    Da ich auf keinen Fall auf meine gut funktionierende Backup Lösung verzichten möchte wollte ich mal fragen ob schon jemand das Backup unter Windows 10 nutzt?

    VG,
    Andreas

    • 8. August 2015, 23:10 | #8

      @Andreas Bank
      Ich teste gerade viel unter Windows 10. Ich habe bis jetzt noch keine Auffälligkeiten beobachtet. Ich gehe davon aus, das HardlinkBackup ganz normal unter Windows 10 wie auch unter Windows 7/8/8.1 läuft.

  7. avatar
    Peter Harzer
    8. August 2015, 22:00 | #9

    Plötzlich startete bei mir vom einen auf den anderen Tag HardlinkBackup nicht mehr. Ich bekomme folgende Fehlermeldung: „Der Dienst „HardlinkBackup Service“ konnte nicht erreicht werden. Das kann das Ergebnis einer fehlerhafter Installation sein. Bitte installieren Sie HardlinkBackup erneut. Prüfen Sie, ob ein Dienst „HardlinkBackup Service“ unter dem lokalen Systemkonto gestartet wurde und ob der Dienst Netzwerkverbindungen herstellen darf (Firewall). HardlinkBackup kann versuchen, den Dienst zu starten, allerdings werden dazu Administratorrechte benötigt.“ Der Dienst „HardlinkBackup Service“ läuft bei mir auf dem System nicht. Im Error-Log stehen Meldungen wie: „ERROR: The communication channel of „SingleServiceClient`1[net.tcp://localhost:47686/Lupinho.Net.Net.Services.ICallbackSessionService]“ has faulted. FATAL: An unhandled exception occured in thread „System.Threading.Thread“: at .Void (System.Object, System.UnhandledExceptionEventArgs)“ Die Antivirensoftware habe ich deaktiviert, Windows im abgesicherten Modus hochgefahren, HardlinkBackup und .Net-Framework neu installiert aber immer der gleiche Fehler. Hat jemand eine Idee? Da mir das Programm über die Jahre sehr ans Herz gewachsen ist, freue ich mich über jeden Hinweis.

    • 8. August 2015, 23:07 | #10

      Hier stimmt wirklich etwas mit dem Dienst nicht. Wenn Du die Windows-Taste drückst und die Anwendung „Dienste“ startest, suche bitte nach einem Dienst mit dem Namen „HardlinkBackup Service“. Der sollte gestartet sein und bei Starttyp sollte „Automatisch“ stehen. Du kannst an der Stelle den Dienst neu starten. Wenn er sich gleich wieder beendet, dann liegt ein Fehler vor. In der Ereignisanzeige von Windows finden sich in dem Fall Hinweise darauf. Wenn Du nicht weiterkommst, dann melde Dich bitte direkt bei mir unter software@lupinho.net; das Problem sollte lösbar sein. Du kannst bitte auch nochmal überlegen, welche Anwendungen Du in letzter Zeit installiert hast, die am System etwas verändert haben; irgendetwas ist ja passiert, dass der Dienst jetzt nicht mehr funktioniert. Diese Info kann bei der Fehlersuche hilfreich sein.
      Viele Grüße,
      Lupinho.

  8. avatar
    Miguel
    9. September 2015, 22:31 | #11

    Hallo lupinho,

    Ich kaufte vor kurzem eine Profi-Lizenz von HardlinkBackup für einen PC mit Windows 7 64 Bit. Mit der letzten Version (2.1.5 Build-8408), der Nachweis von verschoben oder umbenannt Dateien nicht funktioniert, und all die verschoben oder umbenannt Dateien werden immer kopiert. Ich habe eine ältere Version (2.1.0), die ich auf dem Netz (CNET) gefunden, versucht, und mit dieser Version der Nachweis funktioniert perfekt!

    Ist es ein Fehler in der aktuellen Version? Oder ist es wahrscheinlich meine Schuld? Bitte helfen.

    ………

    Hi Lupinho,

    I purchased recently a professional license of HardlinkBackup for a PC with Windows 7 64 bits. With the last version (2.1.5 Build 8408), the detection of moved or renamed files is not working, and all the moved or renamed files are always copied. I have tried an older version (2.1.0) that I found on the web (CNET), and with this version the detection works perfectly!

    Is it a bug in the latest version? Or is it probably my fault? Please, help

  9. avatar
    Jürgen Knauft
    22. September 2015, 12:04 | #12

    Hallo luphinho

    Hardlinkbackup 1.0.1 (507) ist mir heute so unglücklich abgestürzt das
    die ganze Platte nicht mehr erkannt wird, d.h.

    auf die Platte kann nicht mehr zugegriffen werden,
    auch die Plattenbezeichnung ist nicht lesbar.

    welches Programm empfehlen Sie um die Festplatte wieder lesbar zu
    machen?

  10. 23. September 2015, 00:03 | #13

    @Jürgen Knauft
    Hi,
    das ist natürlich blöd, wenn die Festplatte kaputt geht – aber dafür macht man ja Backups… Ich würde zunächst die Festplatte mit checkdsk überprüfen und auch die Sektoren prüfen. Was meinst Du mit „nicht erkannt“? Taucht die Platte in der Datenträgerverwaltung auf oder nicht (wenn nein, geht natürlich auvh kein checkdsk)? Wenn es ein externes Laufwerk ist, kann z.B. auch das Netzteil den Geist aufgegeben haben. Es gibt einfach viele Fehlermöglichkeiten; ohne genauere Informationen wird man Dir nicht helfen können. Bitte schreibe mal, was genau passiert ist, um was für eine Platte es sich handelt und was Du damit meinst, dass man nicht zugreifen kann. Dann kann ich – oder jemand anderes – evtl. mehr sagen.
    Gruß,
    Lupinho.

  11. 23. September 2015, 00:09 | #14

    @Miguel
    Hi Miguel,
    sorry, if i forgot replying to you. If you’re fine at this time with 2.1.0, then keep it for a while. I am working hard to release 2.2.0 this fall; if move detection still makes trouble with 2.2.0, we should investigate this.
    Thanks for your patience,
    Lupinho.

  12. avatar
    Daniel
    23. September 2015, 10:18 | #15

    @Jürgen Knauft Ich würde ja vermuten, dass nicht der Absturz des Programms die Festplatte kaputt gemacht hat, sondern andersherum, dass die sterbende Platte das Programm mitgerissen hat.

  13. avatar
    Jürgen Knauft
    23. September 2015, 18:45 | #16

    @Daniel

    Hallo Daniel,

    das kann ich schon unterscheiden:
    das Fehlerfenster, das nachgefragt hat, ob es einen Bericht am MS senden soll, hat sich unter endloser Vervielfachung mit der Maus über den Bildschirm ziehen lassen bis Windows ganz abgestürzt ist. Die Platte ist eine wenig genutzte 350 GB-Platte die nur für Hardlink-Backups genutzt wird und Datensicherungen der letzten 1,5 Jahre enhält die damit alle verloren wären.

    Um das in der Zukunft zu vermeiden werde ich von nun an 2 Backup-Platten benutzen die ich wöchentlich wechsele damit nicht alle Backups fort sind.

    Meine Frage war allerdings ob es ein empfehlenswertes Recovery-Programm gibt das speziell mit den vielen Hardlinks klarkommt?

  14. avatar
    Jürgen Knauft
    23. September 2015, 18:50 | #17

    @lupinho

    danke für die Antwort,

    an der Festplatte, eine 350 GB WD-Platte, liegt es sicherlich nicht weil definitiv Windows abgestüzt ist und es auch selbst gemerkt hat.
    Es wollte MS eine Meldung schicken, hat es aber nicht mehr getan weil es dedinitiv dafür schon zu kaput war.
    Sich dazu weiter den Kopf zu zerbrechen halte ich für nicht notwendig, sowas passiert bei mir alle paar Monate mal.

    Mir geht es um die Wiederbelebung der Datensicherungsplatte die inkretemtell wöchentlich Sicherungen meiner Daten enthält.

    Ich werde chkdsk mal ausprobieren und berichten was dabei herausgekommen ist.

  15. avatar
    Jürgen Knauft
    23. September 2015, 19:06 | #18

    @lupinho

    ich habe gerade chkdsk drüberlaufen lassen.

    es war ein voller Fehlschlag:

    chkdsk hat zwar die Laufwerksbezeichnung wiederhergestellt,
    aber den Platteninhalt so korrigiert das die Platte nun keinen Inhalt mehr hat.

    kann man eigentlich chkdsk x: /f wieder rückgängig machen?

    Welches Recovery-Tool könnte ich als Nächstes ausprobieren?

  16. 25. September 2015, 09:43 | #19

    @Jürgen Knauft
    Oje. Dann ist die MFT (Datei mit den Verzeichniseinträgen) flöten gegangen. Du kannst „undelete“-Tools versuchen, z.B. Recuva (http://www.piriform.com/recuva) oder NTFS-Undelete (http://ntfsundelete.com/). Ich habe die Tools selbst nicht ausprobiert; hatte nur mal ein anderes (dessen Name mir nicht einfällt) benutzt. Die suchen auf der Festplatte nach Dateien ohne die MFT. Das heißt aber auch meistens, dass man nicht alles Dateien so ohne weiteres wieder findet. Aber Du solltest damit wichtige Dateien wiederherstellen können. Die Festplatte hat aller Wahrscheinlichkeit einen Defekt, denn ansonsten wird die MFT (die redundant gespeichert wird) nicht so einfach zerschossen – egal wie der Rechner abraucht. Ich würde sie jedenfalls nicht mehr verwenden.

  17. avatar
    Jürgen Knauft
    25. September 2015, 20:58 | #20

    danke für die Antwort.

    ich denke eher das Windows in einem schlechten Zeitpunkt abgestürzt ist und dabei zufällig auf die Festplatte geschrieben hat.

    ich gehe davon aus das die Daten noch alle da sind zumal ich ja nur mit Hardlinkbackup in Unterverzeichnisse Backups geschrieben habe.

    Ich fürchte das die vielen Hardlinks ein Problem für ein Recovery-Programm sein könnten.

    Offenbar hatte hier wohl noch niemand das Problem und damit einsprechende Erfahrungen gesammelt.

    Ich hatte mir mal ein Programm namens HDD-Mechanik gekauft und noch auf der Platte.

    Das Programm hat aber nach einiger Zeit seine Tätigkeit eingestellt, d.h. keine Zugriffe mehr auf die Platte gemacht.

    Ich werde sie erst mal klonen (hätte ich schon früher machen sollen!) bevor ich es mit anderen Tools versuche.

  18. avatar
    Jürgen Knauft
    26. September 2015, 22:46 | #21

    anderes Thema: SOUND

    ich fände es gut wenn man einen Sound abspielen könnte wenn das Backup fertig ist.

    Kann es sein das das bei Version 1 ging und jetzt nicht mehr geht oder trügt mich da meine Erinnerung?

  19. avatar
    Jürgen Knauft
    27. September 2015, 19:15 | #22

    Betrift: abgeschossene Datensicherungsplatte
    ich habe Recuva 2 Stunden drüber laufen lassen.
    bis auf den Namen des ersten Verzeichniseintrages ist alles gefunden worden.
    Recuva kann aber die Dateien nur auf eine andere Platte kopieren
    was sich wegen der vielen Hardlinks verbietet.

    Ich suche nun ein Programm das nur das Verzeichnis neu anlegt,
    aber an den Dateien nichts ändert,
    die sind ja auch noch ok.

    hat jemand einen Tipp womit des geht
    (ntfsundelete hat nichts Vernünftiges gemacht!).

  20. avatar
    Uwe
    30. September 2015, 21:48 | #23

    Hallo!
    Ich verwende die Kauf-Version von Hardlink-Backup. Leider starten die geplanten Backups nicht und ich komme einfach nicht darauf, woran das liegen könnte. Es läuft die ganze Zeit ein Tast „HardlinkBackupTray“ aber was ich auch plane, wenn der Zeitpunkt kommt, tut sich nichts.
    Für Hilfe wäre ich dankbar.
    Viele Grüße
    Uwe

    • 30. September 2015, 22:13 | #24

      Das die Tray-Anwendung läuft, ist normal. Wie planst Du denn und welche Fehlermeldung kommt? Du musst in der Planung den Reiter „Zeitplan“ wählen (und gewählt lassen). Nachdem Du Benutzerkennung und Kennwort (eines Administrators) und Startzeitpunkt bzw. Wiederholung angegeben hast, muss die Backupdefinition gespeichert werden. Dann sollte entweder ein Fehler kommen oder das Backup (nach ein paar Sekunden) im Home-Bildschirm unter „geplante Backups“ auftauchen.
      Das ganze funktioniert eigentlich verdammt zuverlässig…

  21. avatar
    Uwe
    1. Oktober 2015, 13:09 | #25

    Ich plane normal wie vorgesehen im Zeitplan-Dialog von HardlinkBackup und eine Fehlermeldung bekomme ich nicht. Das Backup erscheint auch unter „geplante Backups“. Ich gebe Benutzerkennung und Kennwort eines Admins (meines Standardkontos) an.
    Das Ganze funktioniert also nicht über die Windows-Aufgabenverwaltung sondern autark? Mich hat nämlich gewundert, dass bei mir in der Windows-Aufgabenverwaltung zwei Tasks auftauchen, die irgendwas mit HardlinkBackup enthalten, sagen mir aber nichts.
    Mein Backupziel ist ein Netzlaufwerk, aber auch mit lokalen Ordnern hat es nicht geklappt.

  22. avatar
    Uwe
    1. Oktober 2015, 18:27 | #26

    Hm jetzt hat es lokal geklappt, allerdings immer mit ein paar Minuten Verspätung. Und genau diese hat mich auch zuerst zu der Annahme gebracht, dass es nicht geklappt habe. Aber im Netzlaufwerk geht es noch nicht. Ich muss um auf dieses zuzugreifen allerdings öfter mal das Netzwerkkennwort eingeben, das kann HardlinkBkp natürlich nicht alleine. Würde sich das Programm melden, wenn es Probleme mit dem Zugriff hat? Ich bekommen zumindest keine Meldungen über fehlgegangenen Backups, es passiert einfach nichts.

  23. avatar
    Werner
    1. Oktober 2015, 20:20 | #27

    Falls man im ersten Backupsatz eine Datei löscht wird beim nächsten Backupvorgang z.B. folgendes im Log vermerkt

    An error occured while creating a hard link „C:\0ziel\2015-10-01_20.14.40\0quelle\Test1.txt“ pointing to „C:\0ziel\2015-10-01\0quelle\Test1.txt“: File not found —> System.IO.FileNotFoundException: File not found —> System.IO.FileNotFoundException: Das System kann die angegebene Datei nicht finden. (Ausnahme von HRESULT: 0x80070002)

    Die Datei ist in der Quelle noch vorhanden – wird aber nicht nochmal kopiert

    Wäre es nicht besser das hardlink Backup die datei selbst einfach nochmal kopiert ? Kann ja mal sein das auf der Backupseite mehrere Dateien aus welchen Gründen auch immer verloren gehen ?

  24. avatar
    Werner
    1. Oktober 2015, 20:38 | #28

    Obwohl im Backup jetzt eine Datei fehlt, zeigt hardlink ein grünes Vergleichszeichen an – im Notfall wäre dann kein Backup vorhanden ?!

  25. avatar
    Sebastian
    19. Oktober 2015, 19:49 | #29

    Kurze Info für die nächste Version. Das Icon lässt sich nicht an das Startmenü in Windows 10 anpinnen.

  26. avatar
    Andreas Bank
    2. November 2015, 10:37 | #30

    @lupinho
    Danke Lupinho. Wäre so schade auf diesen grandiosen Helfer verzichten zu müssen. Werde in den nächsten Tagen den Sprung wagen und ggf berichten.

  27. avatar
    Sebastian
    6. November 2015, 08:05 | #31

    @Andreas Bank: HardlinkBackup unter Windows 10 im Einsatz und läuft. Bisher keine Probleme festgestellt (meinen Beitrag vom 19.10. zähle ich mal nicht als Fehler).

  28. avatar
    Michael
    18. November 2015, 16:02 | #32

    Hallo,

    ich hab grad mal Hardlinkbackup mit NTFS-rechten ausprobiert.

    Leider kopiert Hardlinkbackup mit der Option „Dateiberechtigungen kopieren“ bei der gesetzten Option nur die Rechte, nicht aber den Besitzer.

    Die Rechte sind auch bei allen Links auf eine Datei gleich – das geht ja bei Hardlinks leider nicht anders. Wäre es vielleicht möglich, eine Option einzubauen, die bei geänderten Rechten eine Echte Kopie anstatt eines Hardlinks erstellt?

    Viele Grüße
    Michael

  29. 30. November 2015, 09:39 | #33

    @Michael
    Der Besitzer sollte eigentlich schon mit gesetzt werden. Hast Du Fehler/Warnungen, die darauf hin deuten, das etwas nicht geklappt hat?
    Für die Handhabung von Berechtigungen habe ich ein paar Ideen, die ich in der demnächst erscheinenden Version 2.2 noch nicht umsetzen konnte (aus Kompatibilitätsgründen). Das müsste dann auch Deine Anforderung umsetzen (es dauert halt leider noch ein paar Monate, bis ich das dann umgesetzt habe… ;()

  30. avatar
    Carlos
    5. Dezember 2015, 14:25 | #34

    Hallo,
    eine Frage die mir schon seit Längerem auf den Fingern brennt: Erkennt das Programm unerwünschte Veränderungen? Also falls eine Datei zB durch lange Lagerung nicht mehr lesbar ist? Ich hatte das des Öfteren bei zip Archiven festgestellt, die sich nicht mehr entpacken ließen. Gibt es eine Möglichkeit zu testen, ob solche Veränderungen geschehen sind, sowohl auf Quell- als auch auf Ziellaufwerk? Im Mirror Modus würde man ja quasi sein(e) Datei(en) verlieren, wenn die funktionierende durch eine kaputte Datei beim Sichern ersetzt würde. Viele Grüße

  31. avatar
    Sven
    7. Dezember 2015, 04:17 | #35

    Hallo Lupinho,

    Ich spiele mit dem Gedanken, mir die Professional License zu gönnen 🙂
    Kriege ich mit dieser Lizenz dann auch potentiell kommende Updates?

    Viele Grüße,

    Sven

    • 7. Dezember 2015, 21:25 | #36

      Du bekommst alle Updates der Version 2.x kostenlos. Wie es mit einem Upgrade auf höhere Versionen sein wird, kann ich noch nicht sagen, weil ich noch keine solche version in Planung habe. Beim Sprung von Versio 1 auf 2 haben alle User das Upgrade kostenlos bekommen.

  32. avatar
    Carlos
    12. Dezember 2015, 09:12 | #37

    Carlos :
    Hallo,
    eine Frage die mir schon seit Längerem auf den Fingern brennt: Erkennt das Programm unerwünschte Veränderungen? Also falls eine Datei zB durch lange Lagerung nicht mehr lesbar ist? Ich hatte das des Öfteren bei zip Archiven festgestellt, die sich nicht mehr entpacken ließen. Gibt es eine Möglichkeit zu testen, ob solche Veränderungen geschehen sind, sowohl auf Quell- als auch auf Ziellaufwerk? Im Mirror Modus würde man ja quasi sein(e) Datei(en) verlieren, wenn die funktionierende durch eine kaputte Datei beim Sichern ersetzt würde. Viele Grüße

    Was meinst du dazu lupinho?

  33. 20. Dezember 2015, 20:27 | #38

    Ja, das geht durch die neue Überprüfungsfunktion von Version 2.2.0!

  34. avatar
    thebigblue
    25. Dezember 2015, 07:57 | #39

    Hallo,

    Habe gestern version 2.2 installiert-mir ist aufgefallen, dass der Schritt „Berechne Checksum“ sehr lange dauert und viel CPU Zeit kostet. Aktuell liegt Hardlinkbackup bei 60% CPU Last, und berechnet seit mehr als einer Minute die Checksumme für eine ca.40GB große Datei.

    Ist das normal? Das ging meines Erachtens in der alten Version deutlich schneller.

    Gruß

  35. avatar
    Andreas
    29. Dezember 2015, 16:43 | #41

    Hallo, Version 2.2.0 beschert mir leider Probleme unter Windows 10 Pro. Der HardlinkBackup Service kracht nach ca. einer halben Stunde nach Backupstart ab. Hier die Meldung aus dem Ereignisprotokoll:

    Name der fehlerhaften Anwendung: HardlinkBackup.Service.exe, Version: 2.2.9111.0, Zeitstempel: 0x5676e93f
    Name des fehlerhaften Moduls: mscorlib.ni.dll, Version: 4.6.1063.1, Zeitstempel: 0x56536496
    Ausnahmecode: 0xc00000fd
    Fehleroffset: 0x000000000053ac99
    ID des fehlerhaften Prozesses: 0x1994
    Startzeit der fehlerhaften Anwendung: 0x01d1419a12a480bb
    Pfad der fehlerhaften Anwendung: C:\Program Files\Lupinho.Net\HardlinkBackup\HardlinkBackup.Service.exe
    Pfad des fehlerhaften Moduls: C:\WINDOWS\assembly\NativeImages_v4.0.30319_64\mscorlib\e407311405320c601b3800cccd2dcaae\mscorlib.ni.dll
    Berichtskennung: b311f642-1197-445b-93d4-d6ee27e9e5e6

    Nach mehreren Versuchen, hab ich nun ein Downgrade auf Version 2.1.5 gemacht. Hier läuft der Dienst einwandfrei durch … Eine Idee was bei mir falsch laufen könnte? Windows Firewall hatte ich zwischendurch bereits deaktiviert, leider ohne Erfolg.

    Gruss Andreas

  36. avatar
    thebigblue
    30. Dezember 2015, 11:41 | #42

    ok, danke für den Hinweis.

    Ich muss jetzt trotzdem nochmal etwas naiv nachfragen: für 1544 Dateien und 1,02 TByte ist momentan die vorhergesagte Laufzeit im „Berechne Checksumme“ Schritt 4 Stunden und 10 Minuten?

  37. 31. Dezember 2015, 16:49 | #43

    @Andreas
    Das ist sehr schräg. Nach der Fehlermeldung würde ich sagen, dass es einen Fehler in einer Microsoft .Net DLL gab. Warum auch immer. Eventuell hilft eine Neuinstallation des .Net-Frameworks. Allerdings benutzen sowohl Version 2.1.5 als auch 2.2.0 dieselbe .Net-Version (4.0). Es könnte sein, dass Version 2.2 andere/weitere Funktionen nutzt, die den Fehler provozieren. Müsste man evtl. mal googeln…

  38. 31. Dezember 2015, 16:51 | #44

    @thebigblue
    Ob 4 Stunden für 1,02TB realistisch ist oder nicht, hängt stark von Deiner Hardware ab. Klingt für mich sehr optimistisch. Das Berechnen der fehlenden Checksummen kommt auch recht spät in die Zeitschätzung von HardlinkBackup rein, daher kann die Vorhersage sehr gut eine „Mondzahl“ sein. Es ist nicht soo einfach, die Backupdauer vorherzusagen… leider. Mich würde interessieren, wie lange es gedauert hat?

  39. avatar
    Christoph
    1. Januar 2016, 16:51 | #45

    Hallo lupinho.
    Eben habe ich mal wieder mein monatliches Backup gestartet. Vorher wurde das Update angeboten, was ich Auto-Installiert habe. Und jetzt wird fast alles kopiert statt verlinkt…
    Einen Grund dafür kann ich nicht erkennen, diverse geprüfte Dateien sind in Quelle und altem Backup identisch und werden nun dennoch kopiert anstatt verlinkt.
    Die Backup-Quelle ist 677GB groß, HardlinkBackup zeigt momentan eine Gesamtgröße von 231GB, 196GB zu kopieren, 35GB zu verlinken. Ich habe mir das Logfile des aktuell laufenden Backups angesehen und am Anfang stehen nur Verlink-Aktionen, dann nur noch Copy-Aktionen. Die ersten 8 Copy-Dateien im Log habe ich jetzt in der Quelle und im letzten Backup angesehen, keine Unterschiede feststellbar.
    Was kann da passiert sein? Im Log finde ich nichts konkretes warum Copy statt Link passiert. Muss ich den Loglevel hochschrauben?

  40. avatar
    Christoph
    1. Januar 2016, 17:09 | #46

    Und noch mehr Fragen bzw. Probleme:
    a) Klicke ich im Startbild von Hardlinkbackup auf ein ausgeführtes Backup, so öffnet sich der Überblick des Backup-Jobs. Dort wird ein Fenster mit den Quellverzeichnissen angezeigt. Das Fenster ist aber nicht scrollbar und die Liste ist länger als der sichtbare Bereich… So kann ich die nicht sichtbaren Quellverzeichnisse nicht bearbeiten und nicht löschen.
    b) Außerdem fehlt im Überblick des Backupjobs die Anzeige der vorhandenen Backupsätze. Da stimmt doch was nicht, oder?
    c) Wie komme ich zurück zur alten Version?

  41. 1. Januar 2016, 18:37 | #47

    a/b) Das Fenster mit den Quellverzeichnissen ist schon scrollbar. Seit 2.2.0 kann man den Bereich zwischen Backupsätzen und Quellverzeichnissen manuell einstellen. Allerdings ist wohl der Default schlecht gewählt, wenn sehr viele Quellverzeichnisse enthalten sind. Wenn Du es schaffst, alle Quellverzeichnisse anzuzeigen, kannst Du den „dicken Strich“ oberhalb der Backupsätze nach oben ziehen, dann erscheint der Scrollbalken bei den Quellverzeichnissen. Ich werde das Problem im nächsten Update fixen.
    c) Du findest die alte Version 2.1.5 unter http://www.lupinho.net/software/HardlinkBackup/2.1.5/x64/HardlinkBackupSetup.msi zum Download.

    Zu Deinem Problem mit der Kopieren/Verlinken: Bitte benenne mal die index.hbi im letzten Backup, mit dem Du verlinken willst, um. Dann wird die index-Datei nicht benutzt. Evtl. behebt das Dein Problem.

  42. avatar
    HLB
    1. Januar 2016, 18:43 | #48

    Jürgen Knauft :
    @lupinho
    ich habe gerade chkdsk drüberlaufen lassen.
    es war ein voller Fehlschlag:
    chkdsk hat zwar die Laufwerksbezeichnung wiederhergestellt,
    aber den Platteninhalt so korrigiert das die Platte nun keinen Inhalt mehr hat.
    kann man eigentlich chkdsk x: /f wieder rückgängig machen?
    Welches Recovery-Tool könnte ich als Nächstes ausprobieren?

    Bei dem von dir beschriebenen Zustand des Dateisystems war das zu erwarten. Da macht man zuerst eines: Retten was es zu retten gibt (idealerweise erst nachdem man ein sektorbasierendes Image angelegt hat, damit man die Versuche wiederholen kann.) Reparaturversuche mit checkdisk und Co. richten da erfahrungsgemäß nur weiteren Schaden an, der eine Rettung erschwert oder gar unmöglich macht.

    lupinho :
    Die Festplatte hat aller Wahrscheinlichkeit einen Defekt, denn ansonsten wird die MFT (die redundant gespeichert wird) nicht so einfach zerschossen – egal wie der Rechner abraucht. Ich würde sie jedenfalls nicht mehr verwenden.

    So weit ich weiß, ist die einzige Redundanz die MFTMirror. Nur ist das keine vollständige Kopie der MFT sondern die enthält nur die Daten für die wichtigsten NTFS-Spezialfiles. Zu mehr, als das Dateisystem wieder in einen konsistenten Zustand zu versetzen, taugt die Kopie nicht.

  43. avatar
    Christoph
    1. Januar 2016, 21:18 | #49

    @lupinho
    Sehr gut! Danke für die Hinweise!
    a/b) Zur Info, ich arbeite mit einer Auflösung von 1366×768 am Notebook und ich hatte keine Chance an den „dicken Strich“ zu kommen. Ich konnte mir aber damit helfen, dass ich so lange Quellen gelöscht habe bis der Strich da war zum Verschieben. Anschließend wieder Quellen hinzugefügt.
    c) Brauche ich hoffentlich doch nicht, denn:

    Nach dem Umbenennen der index-Datei sieht es bis jetzt sehr gut aus (232 von 677GB eingelesen) – es wird alles verlinkt und nicht kopiert. Und ich hatte den Eindruck, dass das Einlesen sogar deutlich schneller ging.

  44. avatar
    Christoph
    1. Januar 2016, 23:24 | #50

    Neues Problem: Backup wird ausgeführt, Einlesen steht in „Warte auf Fortsetzung“, Sichern steht ebenfalls in „Warte auf Fortsetzung“, der letzte Eintrag in der Logdatei war vor über 35 Minuten, die letzten Logzeilen sind „Calculating missing checksum …“. Während der Checksum-Berechnung war die Prozessorlast durch Hardlinkbackup bei relativ konstanten über 50%, jetzt nur noch 2-3%.
    In den Quellen liegen wie geschrieben 677GB, aktuell zeigt Hardlinkbackup eine Gesamtgröße von 254GB, 254GB zu verlinken, verarbeitet 231GB, 231GB verlinkt. Wie um 21:18 geschrieben wurde da 232GB und nicht 254GB bei Eingelesen angezeigt – vielleicht ein Hinweis…
    Ein Klick auf Pause und Fortsetzen im laufenden Backup hat leider nichts gebracht. Scheinbar warten zwei Prozesse jeweils auf den anderen!? Deadlock?
    Was kann ich nun tun?

  45. 1. Januar 2016, 23:42 | #51

    @Christoph
    Bitte lass‘ ihn einfach mal fertig machen! Wie angekündigt braucht das erste Backup länger. Es müssen alle Checksummen neu berechnet werden. Das dauert – je nach Größe – etwas. Wenn es durchgekaufen ist, brauchen folgende Backups dann wieder „normal“ lange.

  46. avatar
    Joachim
    2. Januar 2016, 08:18 | #52

    @luphinho

    Habe das gleiche Problem wie Christoph: „Einlesen“ und „Sichern“ zeigen stundenlang gleichzeitig „Warte auf Fortsetzung“-Meldungen und die angezeigte Restzeit zeigt ebenfalls seit Stunden den gleichen Wert (25 Minuten). Diese Beobachtung ist reproduzierbar: das ist bereits mein 2ter Backupversuch mit der neuen Programmversion. Die Backup-Log-Datei zeigt, das sich das Programm ca 4 Stunden mit der Berechnung der Checksummen beschäftigt hat und gibt dazu für jede Berechnung im Abstand von Sekundenbruchteilen für jede erfolgreiche Berechnung eine Log-Meldung heraus. Die letzte Log-Meldung war kurz nach 2 Uhr heut Nacht:

    [02:05:15.98] MSG: Calculating missing checksum for “ …

    Danach wird nichts mehr protokolliert. Ich nehme an, dass die „Warte auf Fortsetzung“-Meldungen seitdem angezeigt werden. Leider gibt die Backup-Log-Datei keine Hinweise darauf, auf was genau das Programm wartet bzw. warum die Protokollierung abrupt beendet wurde.

    Aufschlussreicher in diesem Zusammenhang erscheint mir die Windows-Ereignisanzeige kurz nach der letzten Meldung der Backup-Log-Datei :

    Ebene | Zeit | Quelle | Ereignis-ID | Aufgabenkategorie
    Warnung 02.01.2016 05:01:10 Boxcryptor 0 Keine
    Informationen 02.01.2016 02:10:48 ESENT 327 Allgemein
    Informationen 02.01.2016 02:10:48 ESENT 103 Allgemein
    Informationen 02.01.2016 02:06:17 Security-SPP 16384 Keine
    Informationen 02.01.2016 02:06:17 Security-SPP 903 Keine
    Informationen 02.01.2016 02:05:58 Defrag 258 Keine
    Informationen 02.01.2016 02:05:57 Defrag 258 Keine
    Informationen 02.01.2016 02:05:57 Defrag 258 Keine
    Informationen 02.01.2016 02:05:50 Defrag 258 Keine
    Informationen 02.01.2016 02:05:47 Security-SPP 1066 Keine
    Informationen 02.01.2016 02:05:47 Security-SPP 900 Keine
    Informationen 02.01.2016 02:05:47 Security-SPP 902 Keine
    Informationen 02.01.2016 02:05:47 Security-SPP 1003 Keine
    Informationen 02.01.2016 01:57:57 ESENT 102 Allgemein

    Kann es sein, daß einer der dort gemeldeten Ereignisse ein Hardlink-Backup-Programm gestört hat?
    Mein Verdacht gilt in erster Linie folgendem Vorgang…

    „Informationen 02.01.2016 02:05:50 Defrag 258 Keine“

    … der ca 30 Sekunden nach der letzter Hardlink-Backup-Meldung
    „Defragmentierung“ wurde von der Speicheroptimierung auf „Speicher (I:)“ erfolgreich abgeschlossen“
    meldet. „Speicher (I:)“ ist das Medium von dem ein Backup angefertigt werden soll.

    Kann ich bzw. (besser noch) Dein Hardlink-Backup-Programm solche möglicherweise störenden Windows-Automatismen für die Dauer des Backups unterbinden?

    Ich verwende derzeit (noch) Windows 8.1. Die zu sichernde Gesamtgröße des Backups beträgt 462 GB, davon 40,6 GB zu kopieren und 421 GB zu verlinken.

    Ich freu mich schon auf Dein Feeback 🙂

    Schöne Grüße & alles Gute (incl. viel Erfolg) im neuen Jahr!
    Joachim

  47. avatar
    Juergen
    2. Januar 2016, 17:06 | #53

    Ich habe das selbe Problem wie Christoph.
    Sowohl Einlesen, als auch Sichern stehen auf „Warte auf Fortsetzung …“ seit Stunden.
    Da scheint ein Deadlock im Programm zu sein.
    Das Backup lief zu 30%, die Checksummen wurden berechnet (für ca 29%)
    Seit 3 Stunden kein Eintrag mehr im Log-File.

    3x erfolglose Sicherungen mir Version 2.2 😉 Version 2.1.5 funktioniert.

  48. avatar
    Simon
    2. Januar 2016, 20:02 | #54

    Habe exakt das gleiche Problem wie Christoph. Man kann 2 Tage warten und es wird nicht fertig. Solange dauert die erste Komplettsicherung überhaupt nicht.

  49. avatar
    toni
    3. Januar 2016, 12:47 | #55

    Hallo,
    also mein Backup dauerte schon so lange wie es bei einem ersten Backup dauert.
    [12:36:43.69] INF: Summary:
    [12:36:43.70] INF: Backup time: 21:21 – 12:36 (15 hours)
    [12:36:43.70] INF: Copied 21,797 files (151 GB)
    [12:36:43.71] INF: Linked 65,126 files (1.13 TB)
    [12:36:43.71] INF: Processed 86,923 files (1.28 TB) in 14,792 directories
    [12:36:43.71] INF: 0 errors and 0 warnings occured
    [12:36:43.71] INF: Backup finished successfully.
    VG Toni

Kommentar Seiten
1 11 12 13 14 15 19 292
  1. 10. April 2015, 10:06 | #1